"Unable to initialize HAL"
Publi� le 4 décembre 2006

Si vous obtenez ce message au lancement de gnome, il se peut que vous ne soyez plus capable d'accéder aux programmes d'administration comme le réseau (network-admin) ou la création d'utilisateurs et de groupes (users-admin).

Il s'agit vraissemblablement d'un problème avec le daemon dbus. On le voit lorsqu'on lance users-admin par exemple en ligne de commande.


$ sudo users-admin

(users-admin:4386): Liboobs-WARNING **: Failed to connect to socket /var/run/dbus/system_bus_socket: Aucun fichier ou répertoire de ce type
4386: arguments to dbus_connection_add_filter() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 4379.
This is normally a bug in some application using the D-Bus library.
4386: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2873.
This is normally a bug in some application using the D-Bus library.

(users-admin:4386): Liboobs-CRITICAL **: run_message: assertion `oobs_session_get_connected (priv->session)' failed
4386: arguments to dbus_connection_add_filter() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 4379.
This is normally a bug in some application using the D-Bus library.
4386: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2873.
This is normally a bug in some application using the D-Bus library.

(users-admin:4386): Liboobs-CRITICAL **: run_message: assertion `oobs_session_get_connected (priv->session)' failed
4386: arguments to dbus_connection_send_with_reply_and_block() were incorrect, assertion "connection != NULL" failed in file dbus-connection.c line 2873.
This is normally a bug in some application using the D-Bus library.

Pour corriger le problème il suffit, en principe, de réinstaller dbus.


$ sudo apt-get --reinstall install dbus

Forum de l'article

# 334 "Unable to initialize HAL" 31 mars 2007, par Khryst
J'ai testé ta ligne de commande $ sudo apt-get —reinstall install dbus mais il me demande le pwd Password :que je lui donne et réponse : are you root ? : le mot de passe que j'utilise depuis deux ans ;-) Donc je ne trouve pas le moyen de "initialize HAL !", j'ai essayé le gestionaire de paquets Synaptic mais en vain. Merci ! si quelqu'un trouve une solution...Salut les geeks !!!
# 335 "Unable to initialize HAL" 31 mars 2007, par Frédéric
Une solution est de booter en mode "sans echec" (recovery mode) et de refaire la manip.
Poster un message